Browser compatibility

To use all of the features on AMBOSS, your browser needs to be updated to the latest version.

AMBOSS is supported by the latest versions of Firefox, Chrome, Safari. Some older versions, such as Internet Explorer 11 or older, do not have the required features and are graphically limited.

We especially recommend using the latest versions of one of the following:

Technically, most browsers in their latest versions should work with AMBOSS! In case you run into any browser issues, please reach out to us via the icon on the bottom right of this page and we'll help you as soon as we can.

Was this article helpful?

Articles in This Section